IF / THEN formula with dates - can't edit formula

I’ve seen versions of this post, but not this specific issue, and I can’t ever get Airtable support to answer my help requests so putting it out there to see if anyone has a fix!

In the “Next Renewal Date Calc” field, I want to add 90 days to the adjacent date in the “Current Period Start Date” field, but only if there is data in that record. Otherwise, I’d like the “Next Renewal Date Calc” field to be blank.

However - it appears I’ve got one of two options.

  1. Don’t do an if / then statement, just do a date add formula in Next Renewal Date Calc, and then it shows an error in the records that don’t have an adjacent Current Period Start. However, it shows the date formatted for human eyeballs.

  2. Write an if / then statement, which returns data as expected, leaving dates only in the fields with an adjacent Current Period Start date. However, it changes the date to a very unfriendly format, and does not allow me to change the format (“Your result type is not a number or a date. Formatting options are currently only available if your result type is a number or a date.”).

I’ve tried changing my if/then formula to a variety of things instead of “” for if the Current Period Start is blank, to see if that helps … tried 0, “-”, MMDDYY … nothing works.

Any ideas?

Thanks!

Option 1 Formula:
ErrorFormula
Option 1 Results:
Error

Option 2 Formula:
If Formula
Option 2 Results:
Filtered

For your 2nd formula, get rid of the final comma & quotation marks.

Hi, just wondering if you can help me out with this one. I’m using the following formula in my table:

IF({Created time}={Last modified time},BLANK(),IF({Travel Updated}>{Last modified time},“:+1:”,IF({Last modified time}=BLANK(),BLANK(),“:warning:”)))

But unfortunately, when {Last modified time} is a few minutes later than {Travel Updated}, is still shows the “:+1:” instead of the “:warning:”. Do you have any suggestions on why can do to resolve this?

I just tested your formula, and it works fine for me. Maybe check the time zone (GMT) option on your fields, to make sure that they’re all set to the same option.