Is it possible to send multi-line text through a webhook link in the airtable button URL?

I’m trying to send multi-line text through an airtable button via webhook to zapier.

Zapier is picking up the text as a single line with no line breaks. How would I send multi line text?

The text that is being sent across is of inconsistent length, so some records will longer and have more lines than others.

Any help greatly appreciated!

Could you share the relevant part of your script where you’re building the Zapier webhook call? I’m guessing your multi-line text is coming from a long text field. Is the rich text option active for that field?

Heya @Justin_Barrett - the webhook url is “https://hooks.zapier.com/hooks/catch///?freestyle_time1=”&{25m Freestyle Time}&"&freestyle_time2="&{50m Freestyle Time}&"&desc="&{Latest Workout Text}

I starred out the unique webhook identifiers (just in case) but you get the drift.

The multi-line text is coming from a lookup. But I also tried it with a Long Text field with Rich Text active and it still spat out one line with no breaks.

Let me know if I’m getting something wrong?

My gut says that you need to encode your field data. Wrap all field references in ENCODE_URL_COMPONENT() and see how that behaves.

That worked! Thanks @Justin_Barrett

Ah except it appears I can’t wrap a lookup field reference in ENCODE_URL_COMPONENT() - the button that holds the webhook just greys out if I try to wrap a lookup field or formula field this way.

Any suggestions? Because I need to send the data from a lookup field.

Lookup fields often return arrays, so you will probably need to force the lookup field’s output to a string by concatenating it with an empty string first. In the middle of the formula, that would become:

...ENCODE_URL_COMPONENT({Field Name} & "")...

Perfecto! Legend @Justin_Barrett

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.