Is there a way to clear/empty a field with a Zap update?

I’m trying to use a find/update zap to automate a record update in Airtable, Some empty fields need to get new data, some get updates and others need to be cleared. The Zap correctly adds the new and updated data, but I can’t figure out how to DELETE data from the fields that I want emptied (which are date fields). With other numeric fields, it’s easy to just set the update value to “0”, but this doesn’t seem to work for date formatted fields.

I’ve tried
Creating an empty dummy field and setting the value equal to that

No luck.

I asked Zapier first, thinking they might have some special formula or syntax to use for this kind of thing, but they told me it’s restricted on the Airtable side and overwriting with blanks isn’t permitted.

I thought I’d ask here in case anyone else has come up with a solution/hack to clear/empty/erase a cell or make it “null”. Thanks.

Hi @Anneka_K - that is something our On2Air: Actions product solves. You can use __BLANK__ and it will clear out that field.

Otherwise I’m not aware of any other approach.

Thanks, I’ll check it out.

@Anneka_K, I don’t know if this will actually work, but did you try empty quotation marks?

Try telling Zapier:

{Date Field} = ""

Thanks Jeremy, I tried but it doesn’t seem to work … I think it did at one point for Text fields, but even that isn’t working any more.

1 Like

@openside I am a subscriber to On2Air, and while __BLANK__ works to clear out a number field, it is inserting that literal text string into a text field in Airtable on update.

How can I clear out a text field?

Sorry @Jon_Thomas1 I mistyped. It should be __EMPTY__

@Anneka_K I stumbled across this thread in search of a similar process - using Zapier to delete data from fields.

In my case, I want to delete a linked record from an entire record. I simply hardcoded two quotation marks into the linked record field in Zapier’s update a record for Airtable. Literally,


…into the field that I wanted to remove the record from. If I review the record’s history (expand it with the arrows), I see the Zapier API has removed it. I’ve used the double quotations in Airtable Formula fields before to leave fields blank if a condition isn’t met, but =BLANK() doesn’t work in this case.

Unfortunately - this doesn’t work for date fields, but as a workaround maybe see if you can covert your date fields as linked records?

If you want the date field still in the table, then you can use a formula field (format as a date) referencing the linked date field.

Hope it still helps your case as it did mine!