Is there a way to limit users to selecting only one record in a linked record field within a form?

Hi everyone,

I’m a pretty new Airtable user, so sorry if this question doesn’t use all the proper terminology.

In short, I’m creating an automated appointment system for my organization. I am using a form to collect user information and create records that track scheduled appointments. Users select their preferred timeslot from a list of available appointment times (achieved by using a linked record field limited to an “Open Timeslots” view in a different table dedicated to tracking availability).

The issue I’ve run across is that I only want users to be able to select ONE appoint time, but the linked record field allows for multiple appointment times to be selected. Is there a way to limit users to one selection with a linked record field? If not, any ideas on how something similar could be achieved?

More details:
I’m working with two main tables: Availability and Scheduling

The availability table contains appointment slot records, the primary field is a date field with the date and start time of the appointment slot.

The scheduling table contains the form view which collects user information like name, email, organization, and their preferred appointment time. It also contains a grid view with records containing the user input.

Availability table, Open Timeslots view:

Scheduling table, Form view:

The live Form, shows how multiple timeslots can be selected in the linked record field:
image

The un-ideal solution I have so far is to just specify that users should only select ONE appoint time in the help text, but I can imagine there will still be a few people who select more than one (not the end of the world for our use case, but not ideal if there is a better solution). Any help is much appreciated!

Welcome to the community, @Brianna_Spears!

Yes, customize the field and turn off the ability to link to multiple records.

Note that this will disable that ability for your entire table, not just the form itself.

1 Like

Ah I see! That worked perfectly, thank you @ScottWorld

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.