Json only returnb 100 rows

I new at airtable, but not to BI, I actually use PowerBI.
I have on airtable a bd (grid) with more than 450 rows.
When I use PowerBi Or CURL to get my data, I only receive the first 100 rows, nothing more, nothing less

And I don’t figure out own to get more data from the table.

Thank you in advance

The Standard API limits GET requests to 100 records. To get more records, you must submit multiple requests with the page offset. The details are in the api documentation.

Pagination

The server returns one page of records at a time. Each page will contain pageSize records, which is 100 by default.

If there are more records, the response will contain an offset . To fetch the next page of records, include offset in the next request’s parameters.

Pagination will stop when you’ve reached the end of your table. If the maxRecords parameter is passed, pagination will stop once you’ve reached this maximum.

In the documentation, nicely hidden in the 5th page, under the List Record menu.

And Power BI doesn’T support Loop and handle badly recursive function.
Everything is here to help
Can we pass an header like “allRecord” that will be sweet !

Sorry, that isn’t possible.

It is actually quite common for APIs to limit the number of records returned to reduce internet bandwidth.

Yes, but AirTable already have the 5 requests by second limit on top of 100 records by requests, so if I have 1000 rows in my table, linked with some other tables that can be as big, it will take a lot of time to fetch all my data.

If you need to get all of your data, it will take multiple requests to piece it all together, and you will have to deal with the rate limit.

If you can get by with only some records, you can reduce the number of records the records returned by view or by filterByFormula. You may also be able to reduce calls to linked records by adding lookup fields to your initial table.

If the page size and rate limit combination is going to be a problem, you might need to look at a different platform.