Keep old linked data

Hello,

I have a table of records that other records in other tables are linked to. I want to see if there is anyway to keep the data in the linked records from updating when I update info in the source record. That way only new linked records going forward would have the updated info from the source record and the old ones would still have the old info.

Example: If price in source record is $5 then when a record is linked the price on the linked record will be $5. Later the price is increased to $10 in the source record but I need to keep all previous linked records at $5 because that was the price when those records were created.

Not sure if this is something that can be done or not.

Welcome to the community, @Jacob_Sessions!

Unfortunately, this is a big limitation of Airtable which most other database programs (such as Apple’s FileMaker) have natively solved within their platforms, but this is not a built-in feature of Airtable.

So unfortunately, you’ll have to come up with a creative workaround to solve this problem in Airtable.

One way to solve this is to create a new product every time the price increases. So, if you’re selling a t-shirt that was once $10 but is now $20, you would create the product twice in your products table. The old orders would still be linked to the old $10 t-shirt, but the new orders would be linked to the new $20 t-shirt. You could also add a checkbox in your products table to indicate which products are the “currently active” products, and then modify your linked record field in the orders table to only show you active products (based on an active view that you setup in your products table).

Another possible workaround would be to create an automation that automatically pastes the current price from your price lookup field into a normal number field, and use that normal number field as the “actual price” of the product, regardless of whether the price lookup field keeps changing into the future.

I’m sure that there are a bunch of other great ideas from other people on how to workaround this problem as well.

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.