Line breaks in Long text that I can't remove

This is driving me nuts. I have a long text field (rich text turned off) that seems to have multiple line breaks.

Formula I used was Substitute(Field,“\n”,“”) and while it seems to work it also doesn’t. I tried with putting in a value instead of “” so I could see it working and it is working but also airtable seems to be keeping paragraphs anyway.

Screenshot 2022-07-06 153000

Any help would be greatly appreciated.

Hi Brent, hmm, so you’ve got a long text field, and you’re trying to strip all the new lines out of it, right?

Could you have a look at this base and tell me where our setups differ? I was attempting to replicate your issue but couldn’t get it to happen, so I think I’m setting it up wrong

Screenshot 2022-07-06 at 1.59.31 PM

Ok I seem to have stumbled onto the solution substitute does not work for \r removal which I had tried already only regex_replace works but only on the original text column not if it is a lookup column.

REGEX_REPLACE(REGEX_REPLACE(Field,“\n”,“”),“\r”,“”)

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.