Link to field omits information

My question concerns missing information using a link field.

In Table A is a field name: Property ID

In Table B is a link field to Table A’s Property ID

In table A I enter London 123

When I search in Table B’s Property ID for London 123, I can find it amongst the records but the 123 isn’t displayed. I have tried entering London-123 but it doesn’t make any difference. how should I enter the information in the table A field to ensure that when I link all the information is displayed in table B?

tia

Hey Michael!

I’m a little confused about your post, so please toss back any more context I might need based on my response here.


Table A’s records are a text string in the format along the lines of “London”.
Table A has a field that holds a number value such as “123”.

You have a separate table (“Table B”) that holds other related data and records.

You have linked the record from Table A to a record in Table B, but you’re only finding the London value, but you are not able to find the “123” value.


Solution:

If that describes your problem, then the functionality that you’re looking for exists in the Lookup field.


Here is a visualization of how this would look.
You’d just need to create a new lookup field, select the link to Table A, and then the field that you are trying to pull data from, in this example, it would be the ID number field.

If I’m missing additional context, please let me know!

@Michael_Lever There’s a slight error in your original post wording:

A link field doesn’t link to a specific field from another table. It links to records from the other table. What appears in the link badge is the contents of the primary field from each linked record. As @Ben.Young indicated, you can bring over the contents of other fields from the linked records using lookup (or rollup) fields, but the only data that you’ll directly see is what’s in the primary field of those linked records.

Thank you. I am not sure whether I understand your answer. I re-explain.

Table A field name: Property ID
New view: ML ID
Customised field type: Single Select
Data: London 123.

Table B field name: Property ID
Customised field type: Link to Table A
select: Allow linking to multiple records
select: Limit record selection to a view.
from dropdown: Table A, select view ML ID

Click + to find a existing record
After found and selected, the data display is just London, not London 123

The only I can get it to display London 123 is by entering the data in a different field in Table A.

Gotta stop now: puppy impatient! will resume tomorrow.

Huh… I think(?) I understand your base schema a little bit better now.

To get the desired result, you will need to adjust how you are thinking about your base schema.
Here’s how you get your desired result:

In order for the linked field to return “London 123” when you search using the linked field, the primary field of Table A needs to contain the value you want to display.

Here’s an example:

…and here is Table B:


Now, since the primary field of Table A now contains “London 123” (and other example values), when you search for “London 123” in the linked field values, you will get those results back with the numbers included.

Why Is This The Case?

The value displayed in the linked field is always going to be the primary field value from the record that is linked. Per your screenshot, it appears that Table A currently has the Location formula field as the primary field.

So, you would have to move the formula field and replace it with the Property ID field in order for you to replicate what’s in my screenshots.

Thank you. I did wonder if that might be the solution. i have other linked fields on this table and on another base without any issue but I hadn’t realised that the data in those was linked to the primary field value.

To achieve what i want to do is going to require a rethink of how I want to display the data.

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.