Linking to a synched table fails from the API

steps to reproduce:
1 create a synched table, say Users and create one user
2 in another db add the synched User table
3 create a table, say Exam, that has a field that links to the user
4 verify that you can, from the Exam table, link a user from the synched table
5 from the API call the create method on the Exam table with the field user : [ user-rec-id ]
6 notice you receive an error 422 ‘Record ID user-rec-id does not exist’

expected result:
You should be able to create an Exam record from the API with a user linked to the synched User table

It’s working okay for me when using the API to create a new record that links to a synced table.

Are you putting the record ID in quotation marks?

And are you choosing the proper record ID (and is it from the table that the linked record field is linking to)?

The cURL data that you’re posting to create a new record should look something like this:

{
"fields": {
    "Text Field 1": "Test data here",
    "Text Field 2": "Hello world!",
    "Linked Record Field": ["recABC123defghi456"]
  }
}
1 Like

Thank you Scott for your reply. After much digging I see that the synched User table in the Exam database has a different rec id than the User in the original database. Problem is solved. Thanks again for the swift reply!

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.