Long Text adds "" arond it on csv export


#1

I am not sure if this is what the proper format is in the case of a CSV file with a multiple lines column, I know it does not happen in a Google Spreadsheet CSV. When exporting a very basic table with one of the columns being a “Long Text” column, the export adds a set of Apostrophe ("") around the text. This causes a huge issue for my use as the CSV file is for importing data into a website via an import tool and the “” trips up the importer causing it to fail. The only way to fix it is to open the file in a text editor and manually remove the “”


#2

Hey there! Is there a comma in the long text value when you’re exporting to CSV? When there’s a comma in the value, double quotes ("") need to be put around the text to avoid splitting the value on the comma (since that’s how a comma-separated value file parses the division between values in different cells).


#3

No, it is regular text. I typed it in fresh. There are no comma’s added in any of the columns. It only shows when opened as a text file. I am actually just creating a test file at the moment. Literally, this is the text I am putting into the field.

This is some kind of description.
This is the second line of the description.

Funny enough if I just click on the cell and cut and paste it picks up the commas, but if I double click into the cell and cut and paste there are no commas.

I am guessing this is some normal formatting within AirTable for long text? I have tried with and without both hard and soft breaks as well as one contiunous line.

I have attached some screenshots.


#4

second screenshot…


#5

Ah, okay, so the issue is the newlines. We also add double quotes when there’s newlines in the text. (For the record, GSheets also adds quotes when there’s newlines in the text.)


#6

Yes, I just double checked, It was the Hard and Soft breaks that were causing it. Luckily I can use some basic HTML and write the text line breaks with to do line breaks.

Maybe a future feature might be an option with CSV export to allow for the automatic insertion of for line breaks instead of the “”

The importer that I am using also allows for basic HTML like , and

etc…" Basically the very basics. Might be useful to some people to have a basic text format window for lo ng text that gives the option to export that text with the basic HTML tags.

Thanx for the help.


#7

Just wanted to follow up on this since it turns out that it was not the apostrophe’s or hard or soft breaks causing the issue with the Squarespace import. It has something to do with the way Airtable makes the CSV file (or Squarespace not recognizing the encoding?). The fix is to simply open the file in a basic text editor and resave it.

I have posted a separate “Bug” post. Not sure if it is really a bug or just a case of incompatibility, but it is possible what causes the issue with Squarespace could also affect something else. And I am sure Airtable would like to be as compatible as possible.