Long text field + export csv causes breaklines

Hello,

I need to make CSV exports of a table that contains several long text field cells.
Each long text field contains text with carriage returns, which results on the csv as actual breaklines, which is makes it quite tedious to fix manually.
Apart from NOT using any breaklines within the long text filed, (which wouldn’t be the ideal solution as we need the information contained in the field to be nicely readable and not showing as a big block), would there be another way to prevent that issue?:pray::pleading_face:
I know the topic has been raised already but unfortuantely I could not find a satisfying answer to that yet.

Thank you for your help!

T.

Hi @Coordination_FLEUVE and Welcome to the Airtable Community! :smiling_face_with_three_hearts:

To be honest, I’m not sure exactly what output you would like to achieve. Can you explain in greater detail? Examples would be really helpful.

When you download the CSV, the entire cell is replicated into a single cell in the CSV. I’m guessing that you’d like to have this information split up so that each line up to a hard return is in its own cell?

1 Like

Hello Nathalie,

thanks for getting back to me. Here is a screenshot of an example
As a matter of fact the content of the long text fields splits up in my scv whereas i would need it to remain on the same line (so that when i convert it into excel i keep all info from that well whithin the very same cell.
Do you see what I mean?

Here this is just an example done of the very fiest lines but when he table will be filloud out with hundres of lines i’m worried about all the tweaks i will need to do manually in order to fix it on the export file.

Thx for your help :slight_smile:

Hmm :thinking::thinking:

Downloading a csv is straight forward for me. This is what I get. Note that I didn’t change anything in the CSV file other than to expand the cell for ease of reading. I wonder if it has something to do with the setting in your computer or Excel maybe. Regional settings I’m thinking. I’m noticing the all the commas which aren’t there in mine.

UPDATE: As an afterthought, try opening it with Excel online.

hum, i though of that at first , so i tried to open the csv not with excel but open it for the first time with notepad ++ or a simple .txt programm, but the breaklines where there anyway :frowning:
I’ll try to investigate that path later on.

Thank you very much for your help.

Hi Nathalie,

just to let you know that you have been super helpful, indeed it was related to my computer’s regional settings.
This works like a charm now :ok_hand::ok_hand::ok_hand:

Thanks again!
Tania

1 Like