Lookup / Rollup of Multi Selects field glitch

When I create a lookup field of a multi select field I get the new updated version seen here

However after reading recommendations in this forum when I try and create and arrayunique() from the look up it is not successful. (See Pictures)


image

I have found that If I convert the lookup to a rollup and back again the I get the result that I am looking for. (See Pictures)


I have gone back and forth from Lookup to rollup and I get the same result every time. I get the feeling that this is some kind of glitch or bug. Please give me any feed back that you can.

See video for better clarification VIDEO

Hmm. Maybe some sort of circular reference? Wonder if @Justin_Barrett has any thoughts on this!

It’s a known bug in Airtable, confirmed by Airtable support. Workarounds in this thread: Rollup Array Unique?

1 Like

Look in the select options. Are you SURE there’s only one of each option?

I was able to replicate what he’s seeing. It’s crazy. :laughing:
Here’s my variety of rollup/lookup/formula fields to try it.

Here’s @kuovonne’s fix:

Thanks, @ScottWorld!

This does not offer a solution that I have not already come up with. If you watch my video in the post that I made I did exactly what was mentioned in the post you mentioned. Do you know if there Is a better solution than what I am already doing?

Wow! That’s totally bizarre! I’ve never hit these precise circumstances to trigger this odd behavior (definitely a bug!), but I’ll certain remember it if it comes up in the future.

Oh, I didn’t see your video link. I’ll have a look at that later. I’m sure I won’t have any solutions for you because it sounds like a bug, but I’ll take a look at what’s going on. Be sure to email support@airtable.com about it.

I will contact support

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.