Mac App won't open on macOS Catalina

I downloaded the airtable mac app but when I try to open it, I get this error message:

“Airtable.app” can’t be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information.

I’m running macOS Catalina 10.15.2.
Is there a fix for this?

1 Like

Use Airtable in the browser instead :man_shrugging:t2:

I believe you could also go into System Pref’s > Security and find somewhere in there where you can loosen the security restrictions on apps.

“Use a browser” wasn’t a particularly helpful suggestion, but changing security settings will fix the issue. I think Catalina changed the text for “unsupported” apps and it makes it sound like you simply can’t run it. After you’ve tried to run Airtable (and it rejects it), open up System Preferences>Security&Privacy>General. There should be a notation about the rejection along with the option of opening it up anyway.

3 Likes

Thanks, it worked. Yeah that changed wording was what threw me off.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.