Mac Desktop not loading tables

Tables are not loading in Airtable Mac Desktop, just spins, but the base shows up normally.

I just upgraded to Mac Big Sur 11.4 and have same problem.

Same on Windows Desktop App. Was working fine yesterday.
Having to use the browser version for now.

I am having the same issue with my Windows Airtable App. I can get into my bases, but the tables will not load. Browser version works fine it seems.

I have since received an email from their support staff:

“Our team is currently aware of an issue that is preventing the desktop app from loading and they’re working to resolve the issue. We’ll be sure to follow up with an update as soon as the issue has been resolved. We have confirmed that the Airtable web app is working as intended, so you can use the browser until we’ve released a fix.”

If you uninstall the app and reinstall, it works, but only as long as it stays open (it seems, as I have not had it open for long while using).

I’m guessing that it’s solved. I keep the desktop app open perpetually on my Mac, and don’t see any issues at the moment.

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.