Making the field names the same on form and table view

I’m currently creating an order form that will populate in the a table. I’ve noticed that if I make a typo in the field name on the form view, the typo will stay on the table view even when it is corrected on the form view. Is there a way to avoid fixing errors twice? This also happens if I enter a field on the table view and change the name on the form view. They end up not matching up.

This may be user error but some guidance would be appreciated.

Welcome to the community, @Leslie_Cooper1!

When you change the name of a field, it changes everywhere across your entire base. To change the name of the field, you will need to click on the name of the field and then choose “Customize Field Type…”.

However, on the form view, you are also given an additional option of creating a “special name” for the field that will ONLY appear on your form. This will not affect the name of your field… it only affects the name that is displayed on the form. This way, you can show your form users a “form-only name” for the field when they’re filling out the form, without affecting your “internal name” of the field. This was really a stroke of genius by Airtable, because your public-facing field name won’t interfere with the name of your field internally.

1 Like

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.