Multiple filters overriding one another

I have three separate filters set up on record view, however they don’t seem to be working correctly. In the attached, I’ve set the Estimators filter to display results for records that have no Estimator assigned. However, records with Estimators are still being displayed.

I presume the Type filter (second filter) is taking precedence over the Estimators filter? All three filters are set as the default ‘Where’ action; it doesn’t give me the option to change this, only add additional conditions to each.

Any help appreciated, TIA!

Hey Jay, it looks like you have three Filter elements set up there

Could you try setting it up so that you only have one Filter element with all the conditions in it? I think that might solve your problem

Screen Recording 2022-06-07 at 5.32.04 PM

2 Likes

Did you link the filter to your record picker element?

Oh, just saw @Adam_C’s post… yes, that is the other problem happening here.

1 Like

Ah amazing, that fixed it! Thanks very much, I was starting to lose my marbles over this :smiley:

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.