My Automation wont turn on even though test works

I have an automation that won’t turn on despite working correctly the last few days. It’s set to create a record when a row is added to a google sheet. Both the trigger and action pass their test, yet the automation won’t turn on. What could I possibly be missing?

3 Likes

Welcome to the community, @Alex_Doucette! :smiley: Try restarting your browser (or the desktop app if that’s what you’re using). Sometimes Airtable flakes out in tiny ways, and a refresh can sometimes fix it. If that doesn’t do it, you’ll need to contact Airtable support directly.

@Justin_Barrett Thanks. I restarted and unfortunately nothing changed. I’ve also tried recreating the automation several times with no change. I sent a loom to support so hopefully they have some insight

2 Likes

I am having the same problem @Alex_Doucette

I am experiencing the same issue! Same on several different browsers.

Double-check that something didn’t change that affects the trigger step. I had something similar occur recently, and it turned out to be related to a change that I’d made to some field’s output, or maybe it was the name of a field (I forget which). Whatever it was, I couldn’t turn on the automation. Once I cleared out the settings of the trigger step and rebuilt it from scratch, it worked.

Yes, building upon what @Justin_Barrett just said, you may also need to re-test your trigger again, too, in order to get it to work.

Airtable will remember that the previous test “ran successfully” even if you change something about your trigger criteria that might make it now fail.

1 Like

Any known issue connected Google Sheets new row trigger?

Nevermind - “Spreadsheets in shared drives are not supported”

1 Like

Just an FYI that Make.com supports shared drives for its Google Sheets integrations & automations.

Check out the screenshot below:

@Alex_Doucette Did you have any success with this automation? I’m trying the same but nothing seems to work.
I turn the automation on but instantly it turns off.

Welcome to the community, @Thais_Sakashita! :smiley: Here are a couple of things to try:

  • Restart your browser. If it’s been left open for a long time, there could be memory hiccups that affect Airtable’s performance (I’ve seen this firsthand, which is one of the reasons why I power my system down every night).
  • Recreate that setup in a new automation. Even more rarely, Airtable will “flake out” with an automation, and the only way to salvage it is to start from scratch. You could also try duplicating that automation and see if the duplicate behaves, but there’s a chance that whatever issue is preventing you from activating it might carry over to the duplicate. A fresh start is the safest way to ensure a truly clean slate.
1 Like