New record not included in Group

My table it is “Grouped” by one field entitled Company. The Group is sorted alphabetically from First to Last. All worked fine, until I added a new record (in the desktop Mac app), which had only text in its “Company” entry, and it is not being grouped alphabetically. The new record just stays at the extreme bottom of the table.

Hi @Michael_Prescott

I don’t know if this will help, but you may have to re-sort the Auto Number field (if you have this field) by selecting the field name, then change the field type to Single LIne Text, save it. Then open the field again and select Auto Number and save it. This will place all the records in numerical sequence.

I have also noticed the same thing in my base, when I create a new record it gets placed at the end of all the records. The method above places all the records in order again.

Mary

I’m curious to know more about what you mean when you say that the new record “had only text in its ‘Company’ entry”. If the new entry had “only text,” what did the others have? Text and numbers? Text and emojis? There’s got to be some logical explanation why it’s not sorting.

I was just trying to clarify that all the records in the “Group by” column only had text entries. There were no numbers or formulas that could have changed the ability to alphabetically sort. The other records are either text, check mark, or a number.

Hmmm. I’d ask for a screenshot, but new members aren’t allowed to attach images until they’ve been active for a bit. Linking directly to outside sites like imgur also won’t work, as new users also can’t post links. However, you could tweak the link a bit and it would go through. Remove the opening “http://”, leave the domain name, and drop the dot, and we can copy it and fill in the gap manually. For example:

imgur com/gkYBEsb.png

I solved the problem: after adding a new entry in the Grouped By column, I had to go back into Customize Field Type and re-alphabetize all the entries.

1 Like