Not seeing the fields of a record linked to the triggering record of an automation

I could have SWORN this was working before the new automations system overhaul a couple of months ago…

So I have a little CRM set up. Three entities are involved here. Farms, Interactions, Tasks.

Interaction - An interaction has a link to a farm (all interactions have a farm). This is the trigger of the automation. When a certain field of an Interaction is updated, the automation triggers.

I want this automation to create a new record in the Tasks table, and use one of the fields from the Interaction’s linked farm to do this. So at the automation’s screen, I issue a:

  1. Create Record (task)
  2. Set the assignee of the Task to the “User” field of the farm, and to do this, in the automation screen:
  3. Click + next to assignee (one of the fields of the task record)
  4. Choose “record from step 1” (the interaction)
  5. Choose Farm, Continue…

And this is where things fall apart. Instead of seeing all the fields in the linked farms table, I don’t see any! I have recorded this quick vid:

https://vimeo.com/642313579/590f0b34f5

So to recap, a change in the Interaction causes the automation to trigger. I want to create a new record, and go from the triggering automation, into the linked farm, and pull one of the fields and use that field for the new Task record, but I can’t get access to any of the farm’s fields!

Please and thank you.

-Brian

I don’t recall ever having the ability you describe. The value of a linked record field is the list of names and IDs of the linked records, not every cell value from the linked record.

I suggest adding a Lookup field to the Interactions table that brings in the Assignee field from Farms.

Ahh yeah you might be right. That’s too bad. Would be clean to not have to use the lookups but that is a good alternative. Thank you.