Number confusion for phone numbers


#1

When I enter a string of numbers, the app confuses it for a phone number or some link. this made it impossible to delete the database or modify.


#2

What is the column configured to be? Is it text or a generic number maybe? I’ve never personally seen a field get formatted as a phone number runless the column is specifically told that phone numbers will be entered.


#3

As Dean said, only when numbers are entered in a phone number field should they be automatically formatted as phone numbers. Ten-digit numbers typed into a phone number field will get formatted as (XXX) XXX-XXXX, though any other number strings won’t, e.g., if the string doesn’t have exactly ten digits.

I’m a little concerned by what you mean when you say that entering a string of numbers causes it to be “impossible to delete the database”—could you elaborate on this a little bit?


#4

Dear Katherine:

The problem is having string of numbers in the text field, single or multi-line. What happens is when I try to change the number, because it became a phone number with underlining, I cannot backspace it to delete or change it. It only gave me a dialogue box that says “complete action using Skype, phone or hangout dialer” The length of the string of letters seems to be random. I have one with 11 numbers with a – in between, and 12 numbers with 2 “-“ in between, and I have one with 7 numbers only.

I uses this for inventory or bank accounts noting the account numbers or the item number, and that gave problem.

Franklin


#5

@Franklin_Tseng - Can you provide a screenshot that shows the column type and some values below it like you mentioned that are varied lengths and still formatted as phone numbers errantly? That might help.

Thanks!


#6

Please see attached. I have tried this and after the 6 number, the underlining and change of color to make it a phone number will occur. This is a long text field. This same problem happened in the single line and multi-line fields.

Thanks for your looking into this.


#7

Please look at the field “specialty”