On record update automation trigger too eager

Hi,

I have an automation that triggers on record update. But it triggers whilst I’m still typing instead of once i finish and press enter. Is there a way i can tell it to wait until the user ahs finished entering the data (aka pressed enter) and then run?

Thanks in advance :slight_smile:

Update,

got a temporary solution in the form of a checkbox that indicates that a cell is ready to have the automation run if its not checked the automation doesn’t do anything.

Unfortunately not. Airtable doesn’t consider the record to be “updated” once a field’s changes are finished. The moment you begin typing, it’s already sending those first characters to its server to save the change, which is also when it triggers the automation.

As an alternative to using a checkbox, one other option is to force a delay before the update occurs. This can be done using a formula field field with this formula:

NOW() > DATEADD(LAST_MODIFIED_TIME(), 1, "minutes")

That will output a 1 no sooner than one minute after the last change in the record. Change your automation to use a “When record matches conditions” trigger that looks for a 1 in that formula field. The moment you make any change, the formula will output a 0, and then after that delay, it will return to 1 and trigger the automation.

NOTE: because of how the NOW() function updates per the docs—roughly every 15 minutes when your base is open, and every hour if it’s closed—the actual trigger time will most likely be much more than a minute, but the benefit is that it will be a hands-off update.

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.