Parabola API Issue - 422 Error

I have been successfully sending data from Parabola to Airtable via the API export, but now I have been receiving 422 errors saying:

{
“error”: {
“message”: “Unknown field name: “Moda ID””,
“type”: “UNKNOWN_FIELD_NAME”
}
}

However, “Moda ID” is a field in my table. Does anyone know why this might be happening? Has Airtable changed something in their API?

And yet, it is reporting in the error message that this is the field name:

Moda ID”

Is it possible you have added a quote to the end of the field name in Parabola?

@Bill.French I don’t think so. Here is the start body:

“fields”: {
“Moda ID”: ["{Moda Id}"],

Okay,[quote=“Josh_Cyk, post:4, topic:31772”]
“Moda ID”: ["{Moda Id}"],
[/quote]

Without seeing the context of this API interaction it’s difficult to assess the cause. Tell us why the field name is a cap “ID” and the curly reference is a proper-case “Id”.

@Bill.French the capital Moda ID is the name of the field in Airtable. The lowercase Id is a field in my Parabola table.

Okay, well - that makes sense, but I keep coming back to the error message… the data of which is not parseable JSON, which, to me, is a clue.

One must ask - why would Airtable generate a message indicating it believes the target field name includes a quotation mark?

The only logical hypothesis I can come up with is the integration script is attempting to write to a field named ModaID" which obviously doesn’t exist.

Furthermore, that field name has no space in it, whereas, your code example above does contain a space, ergo - even if the quote is an errant character that snuck in through a copy/paste issue, you cannot write data to ModaID if the field is named Moda ID.

“Moda ID”: ["{Moda Id}"],

The probability this is an error somewhere in your code is 87,5% in my view and without seeing the code, these are simply hypothesis at this point. But one thing I am 100% certain of is that when Airtable complains about a field name it is right about 100% of the time. :wink:

@Bill.French I remade the Parabola flow and everything is working. Since I copied and pasted everything from my original flow, it appears it was some sort of Parabola bug, even though the API error response appeared to be from Airtable. I’ve let the Parabola team know about this. It was a very frustrating experience, so hopefully they get it sorted out. I really appreciate your help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.