PDF created with Page Designer has no selectable text or links

I have noticed that the PDFs I have created with Page Designer (by clicking the little printer icon) do not contain selectable text. It seems to be a giant image. Not how a PDF is supposed to work.

This is especially relevant when you include a URL field and want this to be clickable. Strangely enough some of my URL fields are clickable in the little preview pane in Airtable. But only some of them.

Of course when I print and save them as PDFs none of them are clickable, because it is not text.

There is an answer to a previous question that suggests using Long Text fields to avoid that problem but that does not work for me (and how should it, since my output is not text?): Some links not clickable in output PDFs from page designer - #6 by ScottWorld

Text is selectable in the resulting PDF, but I’m sure that this behavior depends on how you create the PDF, though. I’m on the Mac, which has built-in PDF creation in every print dialog box… and all the text in the resulting PDF file is selectable.

I am on a Mac as well. How do you do it? For me it is:

  • Print icon in the top-right corner
  • Close the proceeding dialogue with “Print”
  • Open in Preview

The resulting PDF has no selectable text.

When your web browser’s print dialog box appears, you can either choose “Save as PDF” or “Open in Preview” from the “PDF” menu at the bottom of the print dialog box.

Either of those options should work. If those aren’t working, I wouldn’t know how to guide you further. Perhaps send an email to support@airtable.com to see if they can help.

1 Like

Ah, the word “browser” got me thinking.

I was using the Airtable App. If I do it in Safari, the text in the PDF is selectable and the links are clickable.

(Chrome does not work, since I do not get the Mac print dialogue there).

Thanks!

Great that you figured it out! I’m not 100% sure how committed Airtable is to maintaining the desktop app, but you may want to email support to let them know about this broken behavior.

Thanks for going through this with me. I’ve contacted Airtable about this in case they did not know.

2 Likes

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.