Please help with basic formula producing Infinity & the wrong count

I have a formula to calculate how many plants I can fit in a 10x12" square. My formula goes: 10/Spacing * 12/Spacing.

(Spacing is a column where I record the number of inches of distance a plant needs).

The formula works, except for in two instances- 1. When I have not filled out the spacing column yet, the formula produces ‘INFINITY’ as the result. I’d like it to return a blank field instead of returning ‘INFINITY’. 2. When the plant requires two 10x12" squares (i.e. when the Spacing is 24"), the formula produces 0. I would like that changed to 2, or even better, an actual calculation with a decimal, like 1.5, 2.5, etc. Can anyone help? I’ve searched similar issues but can’t find anything that helps me.

Hi @Brittanie_Anderson,

Welcome to Airtable Community!

For your first question, you can do an IF formula that in case Spacing is blank, the answer is blank. If not, then your formula is calculated.

IF({Spacing} = 0, " ", 10/Spacing * 12/Spacing)

As for your other question, check the Formatting of the field, change it to Decimal.

BR,
Mo

Thank you! Everything worked except for now the Formula itself is displaying as a long string of decimals and it is saying “Your result type is not a number or a date. Formatting options are currently only available if your result type is a number or a date.” I think this is because of the blank answer part of the formula. Is there a way to alter the formula to make the results display as an integer or one decimal maximum?

UPDATE: I tried editing the blank display to ‘0’ just to get a number in there, and it still didn’t work.

What is the Field type you have in this column? It should be a Formula field to work. If you put Zero, remove the quotation marks.

Thank you. Removing the quotes fixed it!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.