Prefill Form only takes the first word in my field

Hi,

I am trying to prefill a form using the following formula:

CONCATENATE({Applications URL}, ‘?prefill_Which+role+are+you+applying+for?=’, {Name of opportunity})

The ‘Name of opportunity’ field contains more than one word, but the formula is only pulling the first word. Here is an example of one form’s URL:

When the ‘Name of Opportunity’ is actually ‘Logistics, Freight and Warehousing - DSV’.

How do I ensure that the form populates with all the words?

Thanks!

You need to url encode your prefill value. You can do this with ENCODE_URL_COMPONENT()

You can also used my “Prefilled Forms” Marketplace extension and it will create the formula for you with ENCODE_URL_COMPONENT().

1 Like

You’ll also need to encode any non-alphanumeric characters in field names, like the question mark in the field name in this example. The formula above should be:

CONCATENATE({Applications URL}, '?prefill_Which+role+are+you+applying+for%3F=', {Name of opportunity})

Hi @kuovonne ,

Many thanks for your assistance, but it appears still not to be working.

Here’s the formula I created from your extension:

Apply to our roles today!” &
“prefill_Which%20role%20are%20you%20applying%20for%3F=” & ENCODE_URL_COMPONENT({Name of opportunity} & “”)

And here’s the link to the form, where nothing is populated in the ‘Which position are you applying for’ field:

Let me know if you can pick up anything that’s wrong?

Many thanks,

Jamie

It looks like you are trying to prefill the form with "iLearn KZN LearnershipCC4 Call Centre ". However, that does not appear to be a choice in the form itself.

Is {Name of opportunity} a field in table that the question {Which role are you applying for?} links to?

There also seems to be an issue with the formula when it is pasted into the forum. Try using the </> icon in the forum editor to format your formula.

Hi @kuovonne ,

I want to pre-fill the form with {Name of opportunity}. The options that a form filler can select for the question {Which role are you applying for?} are any of the records present in the {Name of opportunity} field.

I hope that makes sense?

Thanks,

Jamie

Hi @kuovonne it actually now seems to be working! It was just that iLearn KZN LearnershipCC4 Call Centre was not present in the list of {Name of opportunity} because I’d set the field to only display roles that met certain conditions.

Thanks so much for your help!

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.