Problem copying and pasting records

Sometimes I need to copy a record from one table and paste it into another. Until this week, I was able to do so with no problem. However, now I’m having an issue with multiple select fields. For example, one field is for a person’s availability, and they might select three days (e.g., Monday, Tuesday, and Wednesday). When I paste the record into a different table, it creates a new option within that field called “Monday Tuesday Wednesday.” I want the days to remain separate.

Airtable Support said that creating a new option is what’s supposed to happen, but that doesn’t really make sense to me. They gave me a couple of workarounds, which would make the process more time-consuming. Does anyone have any suggestions? Thank you!

Is there any chance the field you are pasting into is a Single Select and not a Multi Select?

Thanks for your response. It’s definitely Multi Select.

I started having this same problem today! I even have this problem when I copy/paste a record within the same table (so the fields are very definitely all the same type). All the options in the “multiple select” field are combined into a single new option. I’m seeing a similar issue with Long Text fields, where line breaks are removed upon pasting. Up until this morning, I was able to copy/paste without the formatting and data being affected.

That’s interesting @Rachel_Stander!

Did you contact Airtable support?

It might be more in their ballpark.

support@airtable.com

Mary

Yes, @M_k, I submitted a ticket to support and am awaiting a response. Thought it was worthwhile to also post in this thread so the OP would know they weren’t the only one experiencing the issue.

2 Likes

Thanks for sharing, @Rachel_Stander! Airtable Support told me that the options are supposed to be combined, and that copying and pasting multiple options (the way we would like to do it) might have been some sort of bug, but that doesn’t make sense to me.

@Andrew_Shapira1 There was no explanation of why the copy/paste behavior changed last week, but support eventually led me to a workaround. When pasting, I had previously been adding a new row and clicking my cursor into the first field of that row, then pasting. If I instead add a new row and check the box to select that empty row, and then paste, it keeps the multi-select data as separate selections and retains the line breaks in the long text fields. Hope this is helpful for you, too!

1 Like

This is really good to know!!

Thank you, @Rachel_Stander!

Mary

Thanks, @Rachel_Stander! I also found that if I copy one or more fields, as opposed to the entire record, the multi-select data stays the same.

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.