Problem with sorting records alphabetically


Many of my records are trapped at the bottom of my base! Attempting to sort alphabetically by one of the key fields isn’t working! Why?


What type of field is the one you are trying to sort by? What kind of value does it hold?


thanks for fast response! The field is text - various publications, like NY Times, etc. I have reporters from different pubs, and the list is alphabetical by pubs.


Strangely, when I attempt to integrated those records into the alphabetical-by-publication list, it won’t happen


So the field contains text, but what TYPE of field is it? Is it a linked record field? Is it a Formula field? Is it just a Single-Line Text Field?


Oh! I … don’t know. to the left of the field name is an icon representing a bulleted list, but I don’t know what kind of field it is.


Like this?


yes. that’s right, it looks like that


when I type in the name of a publication it automatically creates a colored button as field entry


So then your sort menu says “First-Last”, not “A-Z” right?


Yes, it says first to last, not a-z


Those are sorted by the order of the options in the Field menu:

You can alphabetize them by hitting that “Alphabetize” button in the Field menu options.


EDIT – It’s important to note that if you add a new Publication to that list, it will automatically go to the bottom of the list, regardless of its proper alphabetical position in the list; to have newly added options properly sorted, you need to repeat this process of hitting the “Alphabetize” button in the Field Menu options.


Ah!!! Okay, I’ll try…


Well, strangely it didn’t work. they’re still down there. I wonder if they are somehow accidentally entered in some protected format, or were sorted as a group by some other field


Re-apply the sort by clicking “Apply” in the Sort Menu:

EDIT – this can be done quickly in the future by hitting /ctrl+Shift+S (to open the sort menu) and then hitting enter (to reapply the sort).


Got it. okay will do


YES!! Success! it worked.