{Quantity}*{Price} = "Integer"? (Solved)


#1

Hi there :slight_smile: !

I just got a tiny question for the experts of Airtable :wink:

In one of my bases, I’ve got 3 fields :

  • {Quantity} : For the quantity (total) of the things I want to buy
  • {Price} : For the unit price of the things I want to buy

And {Total} where I just wanted to have the total amount of money I need to spend to get those things I want to buy :yum:.

In the field {Total} I simply put the formula {Quantity}*{Price} which works but, I get an integer as a result and I just don’t understand why :thinking: .

E.g. : 2 * $4,49 = 9 but it should be 8,98

At first, the {Price} was a currency field and the {Quantity} field was an integer.
I’ve changed those 2 fields in decimal with the same precision of “1.00” but I still get an integer as a result.

Is there a way to get the exact total price ? :thinking:

Thank you in advance for enlightening me :grin:


#2

How is the {Total} field formatted?


#3

When you click on the formula field type, there are two tabs, formula and formatting. If you click on the formatting, you can choose currency and set it to the decimal precision you would like. Hope that helps.


#4

@W_Vann_Hall, @Cindy_Caverly :+1:

Thank you very much for your help :smile: :+1: !

I simply and really didn’t see the “Formatting” tab when writing the formula :sweat_smile: :blush: .

Everything is back to normal :smile: :wink: