Records disappearing unexpectedly in grid view

Records disappear then reappear when I re-enter the text part of the variable into the filter of a table view. This disappearing can happen when I re-fresh my browser, or when I go to a different table view and then return.

I can both replicate as well as “fix” this behavior:

There are three different fields that can be called on in my filter for this table view …

  • Project - linked field to Project table
  • Discipline - lookup field (Discipline field from Project table)
  • Name - Formula field (concatenate formula that includes Project field)

I can replicate the odd behavior (of records disappearing then reappearing when I re-enter the text part of the variable into the filter) when either:

  • Filter is set to Discipline contains meeting; OR
  • Filter is set to Name contains meeting.

I can “fix” the behavior when:

  • Filter is set to Project contains meeting

Behavior has been functioning fine for many months with the filter set to ‘Discipline contains meeting’. But today is the first time this odd behavior began.

Any ideas as to why this is happening?

I have the same strange behaviour since a few hours with my filters. When filtering by lookup field it all looks fine for a moment, but when refreshing browser it all disappears. That’s definitely not normal.

Asled support for help already as this screws our complete data base usage.

Kai.

I am also having this issue but it will temporarily appear if you add in the filter issue. It might just be a system issue. Hopefully it gets fixed soon.

Hi everyone,

It sounds like this is related to an issue we identified today with filters and sorting. You can learn more about the issue and receive notifications for updates here on our status page.

Update: we have implemented a fix and our filtering and sorting features should be working normally. We’re monitoring the results.

1 Like

Thanks for this update.

Seems there has been a residual issue that happened to our base I believe due to this Filter and Sort issue where all records in one of our tables have had data changed in a single select field.

  • Table view = Open Tasks
    • filter includes Field (Status) is none of “Cancelled” and “Done”
  • Single select field (Task Type) was affected
    • all records in this field changed to the top item from the list

Nothing else appears to have changed and this change only appears to have happened to the records that were in this table view.

  • I looked at our “Master List” view (unfiltered view) and it appears that the records that were outside of the “Open Tasks” view were not changed.

Since this includes almost 50 records and is difficult to reconstruct manually, I am going to restore from the last snapshot - taken May 5 @ 3:26pm.

Wondering if there is another approach to consider.
At the least, I feel this is worth capturing here.

Really love this community.

Sali

Hi Sali,

Sorry to hear that there were some record changes from this. Recovering those records from your most recent snapshot is probably the best approach, but if you run into any issues with that (or anything else) please let me know so I can connect you with our support team to help out.

1 Like

I have the same issue all of sudden !!!

While working my records disappeared

Sorry @Abraham_Bochner, I’ll have our support team reach out to you soon to help out.

@Jason - Restore was a simple (i.e. painless) process and fix for us.
I appreciate your feedback.

Sali

1 Like

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.