Reference looked up emails for automation

Hi there,

I have a communications calendar that I’m trying to have automate some email sends through the Gmail automation. I have my emails on that table as a lookup field, but the automation isn’t recognizing it as an email address so it’s failing the test.

Is there a formula that will basically copy what’s being looked up and just format properly so that it’s an email address?

Thank you for your help!

Amy

Automations don’t currently work with lookup fields, so you will need to create a formula field that equals your lookup field. Then, use that formula field instead.

Hi @ScottWorld, I tried that but it still didn’t work. How can I make the formula display in “email format” so it is recognized properly?

Please post some screenshots of what’s going on!

Screen Shot 2020-10-08 at 15.25.34 Screen Shot 2020-10-08 at 15.24.57

It’s not recognizing that the “formatted emails” column is actually email addresses. The test keeps failing.

So grateful for your help, @ScottWorld :slight_smile:

@Amy_Herman

Ah okay, since you have multiple email addresses per record, your lookup field (and your formula field) are both resulting in an array instead of a text string (which is what the Automation is expecting to receive).

So, you will want to change your formula field to say this instead:

{Recipient Emails} & ""

That will convert your array into a text string, and then it will work! :slight_smile:

And yes, this would be so much easier if lookup fields just worked natively with automations! Wink, wink, Airtable! :stuck_out_tongue_winking_eye:

Screen Shot 2020-10-08 at 16.35.25 Screen Shot 2020-10-08 at 16.35.09
Screen Shot 2020-10-08 at 16.36.37

Hi @ScottWorld, I’m still getting an error. :frowning: Do you have any other ideas?

As I mentioned in your other post asking a very similar question, you can do this with a a single Rollup field using ARRAYJOIN()

2 Likes

@Amy_Herman You might need to re-run your trigger test. Then re-run your action test.

@Kamille_Parks Thanks for the great rollup idea!

Hi @Kamille_Parks, I’m not seeing the email field since I’m not linking to it directly. I guess I have to rebuild my base in order to follow your suggestion so that I link to email directly instead of participant name. I’m trying to avoid that if possible.

If you have a working Lookup field, which I can tell you do based on your screenshots, you should be able to add a Rollup field using the exact same process you did for the Lookup field.

1 Like

Woohoo! I got the Lookup field to work. Unfortunately, I’m still getting the error I mentioned above. Here are some fresh screenshots.

Screen Shot 2020-10-08 at 23.16.40 Screen Shot 2020-10-08 at 23.16.50

@Kamille_Parks I think the ARRAYJOIN() fixed it! I think you and @ScottWorld are going to keep me sane. Thank you for your help (and for repeating yourselves). I have my automation set to run tomorrow, so wish me luck!!

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.