Remove Byte Marks "%EF%BB%BF" added to Formula URL

Hi, I am generating a URL by concatenating a URL string and then the Airtable record ID. Between my URL string and that ID, there is always a byte mark like “%EF%BB%BF” added (for example, when using the URL in an email automation). Any way to remove that since the URL leads to a 404 otherwise?

How are you concatinating the the URL string and the record ID? I don’t get a BOM when I concatenate and send that URL in an email. I get som extra text string though. Weird.

I did CONCATENATE(“URL-String”, {Record ID})
Or just “URL-String” & {Record ID}. Both caused the BOM.

I helped someone else with this exact issue the other day, though the data was different (a number, not a URL):

How are you creating the ID? Your latest example is using a field reference, so my hunch is that this field is likely a formula that uses the RECORD_ID() function. However, this function can be added directly to your other formula:

"URL-String" & RECORD_ID()

If you still get the BOM, you could try wrapping one or both pieces in the TRIM() function, which is supposed to strip whitespace from the ends.

"URL-String" & TRIM(RECORD_ID())

…or…

TRIM("URL-String") & TRIM(RECORD_ID())

That worked, thank you!

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.