Saving individual PDFs from Page Designer Block

Hi there! I am working with a company that is using the Page Designer block in airtable in a unique way. I use it to make individual “profiles” of possible applicants out to my customers.

I do not have a high number of applicants creating profiles (maybe 3-5 a day). So I go through and tweak/edit each individual profile layout on my own. But I run into a problem when I go to save the individual profile that I finished editing as a PDF.

I have certain topics/fields bolded on the airtable block, and when I hit the “present” button it looks exactly the way I want it to.

But when I press print to then save as a PDF, the bolding of all the text boxes that I’ve chosen to be bold, goes away. And I cannot get it to save looking like how it needs to.

I have a windows working on 10, and one of my coworkers has a windows with windows 10, and one has a macbook. The macbook does not have this issue, but the other person with a windows does.

This being fixed for us is paramount to running the business successfully! Please help!

Hi Madelyn,
Hope you are doing well,

I can assist you with the same.
PM sent, please check.

Stay well!
Maria J

Hello, i need help with this same exact thing. Can you help me too?

I also have the same issue with losing my bold text.
I have used “weight” to make it appear bold in preview/present.
However upon printing or PDF-ing the line weight looks the same. Very frustrating.

That is exactly what mine is doing too Sarah! Erg!

I am currently in the middle of an email thread with airtable support, and they are confused by the issue as well! Not sure what’s going on and/or why this is happening. :face_with_raised_eyebrow:

As I hear back I will let you know. One thing they told me to try was that I should see if it would work if I used an “incognito browser”, this is apparently helping some people. But did not solve my issue… Here’s to hoping we can get this figured out!

I’m curious what AT support says. I’ve found that doing the exact same process on a Mac retains all the text weights assigned - on a Windows 10 machine the text weights are not retained.

I’m just using the print function in AT and printing to PDF as the destination in Chrome.

Thanks Madelyn, looking forward to what they have to say.
I hope the Airtable support staff can figure this out!

Edit: Oh and I am currently using Chrome on Windows 7 Pro. Doing the same as Roger_L, just printing with the AT print function and either printing directly or printing to a PDF.

Is the way that you guys are doing it with the AT and printing PDF keeping the text weights when you do it that way? I feel like that is what I am doing but it does not seem to be solving the problem o_O

And! I’ll for sure keep you guys posted on what they say about the issue… So far there isn’t anything that they have told me to do that has worked, sigh

That is the way I am currently printing and it is NOT working. I don’t think I have any other way to print.

I thought I could maybe print from the preview/present screen, but there is no option to print and CTRL+P just kicks me out of the preview screen.

The PDF version of your profile may not be able to load up the needed font correctly on a Windows computer. The Mac computer may have access to the needed font or may have a different PDF Viewer program that does a better job of substituting the font if it’s not available on the computer.

This might not work but is worth a try…

As an experiment, try using a different font to see if it makes a difference. You might be able to find a font that works on both computers. I would add a bunch of Text elements with the word “Test” all using different fonts to see if you can find something that works. Maybe try 5-10 different fonts?

Best of luck!
Gwynn

That’s it! At least for me.
Apparently “Inter” is not a font my computer recognizes in bold…?
None of the available fonts in Airtable are the “normal” fonts I am used to working with so I guess this makes sense.

Now I have to search through for those that have the option for BOLD and fit the spacing off my current layout… sigh. “ABeeZee” is only available at 400. “Gothic A1” might work.

Glad to hear it worked for you! Thanks for reporting it back.

This was SO helpful! Thank you guys, changing the font completely fixed my issue for the way I’m using it! I let the AT support people know that the issue was font specific, and they said they are going to work to resolve that as soon as they can!

I was using font “Inter” before and it was not working, but am now using “Noto Sans” and it IS working. Droid Sans also works well!

Way to go crew! We solved this issue and I’m so happy about it! Thank you everyone for the help!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.