Showing Time Worked


#1

This should be a simple work flow. I am pretty sure I am missing something basic and simple. When I start a task, I input the start time. When completed, input the end time. Pretty simple so far. In the example below we see I worked from 4am to 17:36 in the evening. That should be 13:36 hours worked. The table gives me 00:00. What am I doing wrong? Thank you to anyone who can help me with this relatively simple (I assume) issue.


#2

Make sure “Use the same time zone (GMT) for all collaborators” is enabled for both date fields and then in your formula change “h” to “seconds”


#3

Hot Damn! That worked. I don’t really understand why… but it worked. I don’t understand why Seconds would output the time format I want (hours and minutes)… but it Does indeed work. Thank YOU!


#4

Duration field uses seconds as the unit, as you pass 23,5 hours (aprox), that number is used as seconds, so you get 0:00:23, but formatted as h:mm so you just get 0:00.

I recommend you to read the help article, you can even not specify the unit in DATETIME_DIFF: