Sorting base in two lists

I have added a number of records to a database of about 500 records in total. When I sort the base, by any field, it sorts the records in two “batches”. Less than half of them from A-Z and then the rest again from A-Z. It makes it impossible to check for duplicates and completely baffles me. There was a previous tip about deleting hidden leading spaces. I have checked for this and this is not the case for me, also that would not affect sorting on every field. Any suggestions?

Are your records grouped?

Hi Scott! No they are not.Two fields are hidden, otherwise nothing has been “applied” except the sorting.

Weird. I would double-check for the leading spaces. Airtable doesn’t actually visually show you any of your leading spaces — which is one of my all-time top pet peeves & annoyances of Airtable — so you actually have to painstakingly & laboriously double-click into each field to make the leading spaces appear.

It really is weird. I did check leading spaces and found them in one of the fields, deleting them there made that field sort right. But the three name fields have no leading spaces and still sort first 155 records, then starts over with the remaining 300 :flushed:

Can you post a screenshot of some of your records, along with a screenshot of your sort settings as well?

Also, I’m wondering if there is some invisible character that you can’t see at the beginning of your text. What if you completely delete all the text, and then manually retype the text from scratch? Does that fix it?

If you create a formula field based on one of the fields with TRIM(), does it the formula field sort correctly?

For example, if the field name is Name, create a formula field with the formula TRIM({Name}) and see if the formula field sorts correctly. If the formula field sorts correctly, you have hidden leading spaces. If the formula field still doesn’t sort correctly, then it is not an issue with hidden spaces.

Also, if your field values start with numbers, Airtable does an unusual sort where it tries to combine a numeric sort with an alphabetical sort, which can have unexpected results.

1 Like

Thank you both, with your input I found a solution that works, even if it still baffles me. Eventhough there are no hidden spaces that I can see in front of the content, if I add a space and then delete it, presto the record sorts correctly! So now I just have to slog through a manual edit of those records and I am all set.

If you created the formula field with TRIM() you can copy/paste the formula field value back into the original source field in bulk.

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.