Text copied out of long-text field has doubled line-break characters

I’m trying to keep my team’s resources all in the same place, including some very simple fill-in-the-blank text boilerplates. The text contains and
tags for styling already because one of the platforms it will end up in, for some reason, interprets strings of more than one line-break character as something it needs to preserve, so it automatically adds a

  to “preserve my intent”.

I’ve noticed that I can copy text into an airtable long-text field (with or without Markdown turned on) that’s formatted like this:

Some random text
More random text
And some more

but when I copy it back out to plain text it looks like the invisible \r\n at the end of the line has been turned into \r\n\r\n like this

Some random text

More random text

And some more

Is there a setting to fix this, or will I need to remove the extra line breaks from everything that comes out of an airtable interface? (I already have the expression for it (\r\n){2,}, I just don’t look forward to teaching people who barely understand html how to use a regular expression.)

Hi Andrew, and welcome to the community.

You need to be more specific. When you copy it back out - using what and to where exactly?

Hi bill, thanks for the reply!

I’m copying it to the windows pasteboard using Ctrl+C (bound to a key on my mouse), then into a plaintext .html document open in the Atom.io text editor, to be pasted into a template box on eBay after editing.

It looks like I may have also been wrong when I said this happens with markdown turned off. I’ll need to rethink that.

That’s a number of transitions, each of which have the capacity to inject unwanted formatting. But, I’m pretty sure you haven’t shared the origin of the copied content when you apply the very first Ctrl-C.

Advice - you need to experiment with a copy buffer besides the one driven and managed by the keyboard. Have you tested these hops using context menu options such as tight-click-copy?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.