TRIM formula for LOOKUP fields

Hi Airtable Community,

When applying the TRIM function to fields that are lookup fields from another table I receive an error. However when testing other formula’s E.g. Concatenate that does work this particular situation using Linked/lookup fields from another table. I would assume that the all functions gather data in the back-end in the same way. Can one confirm this is actually not possible to use TRIM in combination with Lookup Field type?
Thank you

Hi Michael. I just tried it and got an error like you. Then, I concatenated an empty string onto the end of the lookup, to give the TRIM function a string (assuming Airtable returns string after the “&” operator).

It works. So give it a try.

Thank you so much. Odd this is the solutions but adding &"" does the job.
Have a great day.
Thank you

Welcome to the Airtable community.

You are seeing this behavior because the TRIM function requires a string as an input, but an lookup field is an array.

There are multiple methods for converting an array into a string. The CONCATENATE function is one method. Concatenating the lookup with an empty string with & "" also converts the array to a string. Yet another option is to use a rollup field instead of a lookup field.

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.