Unable to Install Blocks

It’s Aug 2021. I read the posts from 2020. No help. Just starting here. Trying to do Hello World App., But on OSX Catalina (10.15.7), Blocks will not install.

I tried the suggestion from 2020: “npm install -g @airtable/blocks-cli@0.0.52”

Either way, lots of warnings about “Please upgrade to version 7” and then failure:

npm ERR! code ENOENT
npm ERR! syscall chmod
npm ERR! path /usr/local/lib/node_modules/@airtable/blocks-cli/node_modules/loose-envify/cli.js
npm ERR! errno -2
npm ERR! enoent ENOENT: no such file or directory, chmod ‘/usr/local/lib/node_modules/@airtable/blocks-cli/node_modules/loose-envify/cli.js’
npm ERR! enoent This is related to npm not being able to find a file.

It would be great to get off step one. Thanks in advance.

Hi @Marc_Solomon1,

Erin with Airtable Support here - sorry to hear of the trouble with this!

The Blocks CLI latest version is now 0.0.64, so you’ll want to just use this command:
npm install -g @airtable/blocks-cli
to install the latest, rather than installing v0.0.52.

But first - I’ve seen the error you’re encountering before, and it usually occurs with node version 15. This thread has more information - can you check if you are running node 15, and if so, follow the instructions there to use nvm or a similar tool to run v14.15.0 instead? After that, re-try installing the blocks-cli and let me know if it works. Thanks!

Thanks. i got it to work. I couldn’t figure out nvm for the life of me, but I found a version 14 download at node.org and reran the installer.

1 Like

So this is expected?

$ node -v
v14.15.0
$ npm -v
6.14.8
$ npm install -g @airtable/blocks-cli
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated @hapi/joi@15.1.1: Switch to 'npm install joi'
npm WARN deprecated @hapi/bourne@1.3.2: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/address@2.1.4: Moved to 'npm install @sideway/address'
npm WARN deprecated @hapi/topo@3.1.6: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
npm WARN deprecated uuid@3.0.1: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
~/.nvm/versions/node/v14.15.0/bin/block -> ~/.nvm/versions/node/v14.15.0/lib/node_modules/@airtable/blocks-cli/bin/block

> core-js@3.6.4 postinstall ~/.nvm/versions/node/v14.15.0/lib/node_modules/@airtable/blocks-cli/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:
> https://opencollective.com/core-js
> https://www.patreon.com/zloirock

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.3.2 (node_modules/@airtable/blocks-cli/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/@airtable/blocks-cli/node_modules/watchify/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

+ @airtable/blocks-cli@0.0.64
added 921 packages from 460 contributors in 43.142s
$

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.