Update record action failing - "error: received invalid inputs."

I’ve set up an automation that consists of a trigger (which works), a script to get the automationTime (which finally outputs the current date in ISO format), and an Update Record Action (which should capture the outputted Date—from the script—and input it into an empty Date Field of the same format).

I don’t know why it’s failing, and what invalid input it’s referring to. Some assistance would be greatly appreciated.

Please see screenshot attached for reference.

Thank you!

I don’t know how to solve your particular problem, but are you simply trying to put today’s date into a date field?

If so, you could just create a formula field with the function TODAY(), and then in your automation, tell Airtable to update your date field with that formula field.

1 Like

Thanks so much for your reply. I tried your suggestion, but it looks like the error is persisting. Have I applied it correctly?

Not sure, but I would try re-testing the trigger and then re-testing the action.

@ScottWorld your suggestion was actually very helpful, and a simpler option than what I had there before, so thanks for that.

The reason why it wan’t working altogether was because I placed a field (Experiment Code) in the Record ID input field. After @Courtney took a look—she pointed it out and my automation was finally good to go!

Cheers! @Airtable community is strong! :muscle:t5:

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.