Using Automations to Check a Box When Record Matches Conditions

Hi Community! I need some help.

Trigger Conditions:
When Date Field (“Date Last Used”) is after 12/31/2019

Action Conditions:
Update existing checkbox field (“Reviewed 2020”) to Checked

Trigger seems to work fine, I just can’t get the action to go. I think it’s because I’m not exactly sure what to input for Record ID.

Thanks in advance!

I have the same question, but in reverse: trying to reset to “To do” or unchecked daily.
It seems like one has to specify each record by ID, which makes no sense. What if I had 5000 records to list in the Automation setup window?

Welcome to the community, @Lia_Marley and @Brendan_York!

You don’t need to literally specify a Record ID (although you could, if you wanted to).

You just choose the step from which you want to pull the Record ID from, and then choose “Record ID” from that step. Airtable will then substitute the appropriate Record ID when the automation is run.

Check out the screenshot below.

Thanks for the welcome and the quick reply, @ScottWorld!

I was able to get it to work for 1 record when I tried that and clicked “Test”, but then it stops even though I turn on the automation:

Since Temp is before today for every record, it seems like the automation should keep being triggered.
Any idea how to make it uncheck all records when any one record is past the due date/time?

Two things:

  1. Once you turn on the automation, it will only run on records that NEWLY match your trigger from that point forward. It won’t go back and trigger on older records that matched your criteria in the past. So, to re-trigger on those records, you could just clear out their date fields & then repopulate them again with the exact same information.

  2. If it’s still not triggering on those records, then it’s likely a time zone mismatch error. You’ll notice that in your automation, your time zone is set to CEST. But your “Temp” field might be set to GMT time zone, if you’ve enabled the option that says “Use the same time zone (GMT) for all collaborators”.

For more information on working with multiple time zones in Airtable, check out my sample time zones base & time zones training video here:

I checked the time zone issue and that GMT option wasn’t selected. But temp was a testing field which will be “last modified date”. I’m hoping the automation will trigger itself as soon as last modified date becomes yesterday. I’m testing now, but have to wait a day to see if it works. Thanks again for your help!