Value function returning Error

Hi beloved Airtable Community!
I’ve got an issue with a VALUE formula.

I have a Rollup field that does a ARRAYUNIQUE job from a Lookup Field which is formatted as a % (i.e. 36%).
The output I get from the Rollup field is a string (i.e. 0.357142852346992).
I tried various ways to convert it back to a number like:

  1. Within the formula of the Rollup, try VALUE(ARRAYUNIQUE(values))
  2. Create a new formula field that performs VALUE(ROLLUP FIELD)
    But both outputs give me “#ERROR

I’ve read some articles about VALUE behavior but not sure to understand how it might help in that particular case.

Would you have any hints?
Thanks a lot, appreciate it!

Can you post a screen shot? If you are rolling up a number field, you should not be getting a string with the formulas you have posted. Instead, you may be getting an array of numbers (even if it looks like a single number).

Try this formula in the rollup …

MAX(ARRAYUNIQUE(values))

or this formula …

VALUE(ARRAYJOIN(ARRAYUNIQUE(values), "")

Hi kuovonne,
Many thanks for your help, MAX function worked it out!
No idea why that worked - and not VALUE - but I’ll remember the trick :wink:
Have a nice day!

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.