View order in the field "Link to another record"

I am using the field “Link to another record”, allowing linking to multiple records. The order of the linked records matters, as in this case, it shows the order of authors of scientific papers.

I enter the linked records, one-by-one in a specified order, for example:

1st author: John Smith
2nd author: Jane Doe

But the resulting cell shows them in reversed order:
Airtable

However, if I copy the cell into any textbox, I’ll get the linked records in the correct order:

John Smith, Jane Doe

Perhaps this is a bug. But anyway, it’s counter-intuitive.

I’ll appreciate your insights regarding this issue.

Cheers.

Here’s my own, similar test:

Linked Records
gggg, zzzz, aaaa

Copy/Paste Values
aaaa, zzzz, gggg

The Linked Record field displays them in the order they were added to the field - with the most recently added appearing first. Honestly, that’s not all that unintutive. But it is unintutive that the copy/paste flips the order. If that’s not a bug, it is a design flaw imo.

Workarounds

Formula

Linked Records
gggg, zzzz, aaaa

Linked Records Formula
Formula: {Linked Records}
aaaa, zzzz, gggg

The formula field seems to behave the same way as a copy paste when attempting to mirror the linked values. So if you just need to operate on the text data based on order, creating a formula field like this would be sufficient. Otherwise…

Drag and Drop

If you expand the record, you can drag and drop linked records to rearrange their order.

Add in Reverse Order

As you may suspect, going forward, you may want to link the records in the opposite order than you have been.

I see the same behavior.

By the way, you an also change the order of linked fields after the fact. In the grid view, expand the field so that it appears as a larger list, and then you can drag to rearrange the order.

Thank you @Zollie & @kuovonne for you replies. I know that I can reorder the linked records after I entered them, but I think the cell content (copy and paste) and what is shown should behave the same way.

It’s worth mentioning that The field type “multiple select” behaves in the opposite way:

The 1st selected option is shown first, the 2nd option second, and so on.

If there are any of the Airtable staff around, I would appreciate your opinion.

I agree. You might want to make a new post and tag it as a product suggestion

1 Like

Thanks @Zollie for you suggestion. Will do that as soon as I get my computer back :grin:.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.