Help

Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

AirTable Automations Are Breaking My Links

Topic Labels: Automations
2639 20
cancel
Showing results for 
Search instead for 
Did you mean: 

I have built an automation that fires off an email to a key stake holder with information found in different fields.
One of these fields contains a link. When the automation fires, the email is sent along with a slack notification.

The slack notifaction contains the same information the email should, BUT the link in the email is altered by the automation and the link in the slack message seemingly works.

The automation is grabbing the same URL from the same field. I am not sure why the URL is changes in the email but not the slack message.

To add additional information, the email is removing the under-scores from the URL and the Slack message is not.

Can anyone help?

20 Replies 20

Can you screenshot that portion of the Automation for both you Slack and Email steps?

Screen Shot 2020-10-21 at 11.20.39 AM

Screen Shot 2020-10-21 at 11.20.49 AM

Weird. It may have something to do with Email’s message field doing something weird with markdown formatting. Try doing [Link to doc](Record (Step 1: Trigger) | Field values | link to Doc).

If that doesn’t work try using the exact same text as your are in the Slack message.

Welcome to the community, @xavier_williams! :grinning_face_with_big_eyes: What triggers the automation? My first reaction when automations contain incomplete information from a record is that the automation is firing in the middle of an update. However, if only the email is being affected and not the Slack message, that would seem to shoot down that theory, but I’m still curious to know what the trigger is.

I tried using the same text and it still is not work out for me. The slack message is sending the proper link. And the email is removing the under_scores from the link.

Did you try formatting the link as a markdown link using the (display text)[actual link] syntax?

How do I do that? Within the automation or within the table?

Within the automation. Precede the input from the trigger record with (some display text) and wrap the input value with square brackets. I’m not sure if that’ll work but it might be worth a shot.

I gave that a shot, and it did not work either.

I ran a quick test that confirmed this markdown connection. Apparently the field data is inserted before markdown processing occurs, so underscores that come from fields are viewed as italics highlight markers.

Screen Shot 2020-10-23 at 5.34.54 PM

The way I got the second URL to pass through was by using a formula field that adds a backslash before each underscore. It was a longshot because backslashes are often used in strings to “escape” a character that should not be processed normally (e.g. quotes in strings), and sure enough it works to “escape” the underscores so that the markdown process ignores them. Here’s my formula:

SUBSTITUTE(URL, "_", "\_")

Insert that formula field in the email body, and it’ll work.

Screen Shot 2020-10-23 at 5.39.56 PM

Screen Shot 2020-10-23 at 5.40.17 PM

Does anyone have suggestions on how to fix this if it’s just a test field? I have values with underscores in them that are getting stripped out with the email automation.
example:
Company_Campaign_Date_032421

I tried the above fix but I just get a blank in that spot on the email send.
Thanks!

@Jeannie_Ruesch_BDC Can you share a screenshot showing what you tried? I’m guessing something might be a little off, but without seeing the details it’s hard to say what that might be.

You can also try inserting the url in markdown format. [square brackets around the text to display](https://parenthesis.around.the.actual.link) make sure there is no space between the closing square bracket and the opening parentheses.

Sadly, this only works when the field is a normal URL field, or if you hardcode the URL into the message body itself.

If the field is a formula field that results in a URL, it fails. :frowning:

I’m going to report this to support@airtable.com, and hopefully they will fix this at some point.

Hi! I can’t get this to work. Do you know if this solution is still possible? When i try to make a formula field that uses your formula, the link is still broken when inserted into the email.

The quickest way I got this to work was by setting the text to Markdown syntax. Using tick marks… It removes font formatting, but it maintains “_” without having to create yet another column.

apiKey is your secret API token.

FWIW. I had the same exact issue that started this thread and followed the instructions presented by kuovonne (above) and it worked for me. Thank you.

me too. When I inserted a field into the body email, it’s show the whole url in the result.