Attachments in gmail - Automations

Topic Labels: Automations
3713 9
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

This is related to sending an email using gmail with attachment stored in the Airtable record.

I am trying to add the attachment which is stored in the table as an attachment field but , the automation is not able to resolve the attachment field.

Am I doing something wrong?

9 Replies 9

Could you please share more details re: the process you’re using to add the attachment? Screenshots would be very helpful. It’s tough to know if you’re doing something wrong when we don’t know exactly what you’re doing. :slightly_smiling_face:

Hi Justin,

I appear to be having the same issue. Within the Gmail Automation, I wish to add an attachment to the email to be sent out. I want the attachment to come from the attachment field of the related record. However, when testing this, Airtable appears to be unable to pull through this field type. See screenshot below:
Screenshot 2020-10-05 at 14.21.36

Thanks for your help.

Welcome to the community, @Tom_Harwood! :grinning_face_with_big_eyes: Check the response I posted in this other thread:

Thanks Justin, that worked! I hadn’t originally included a file in the attachment field for the record it was using to test before I tested the trigger. I’ve since added an attachment and refreshed the trigger test and now the action test is working.
Appreciate the speedy reply!

6 - Interface Innovator
6 - Interface Innovator

Thanks Justin. It worked.

Hi Justin. I am facing the same issue. Have followed the steps above and yet the “attachment” field is blanked out in automation. I checked the test data and 2 attachments appear to be present:

attachment screenshot

would appreciate some help here.

P.s. my attachments are lookups from another table

7 - App Architect
7 - App Architect

I might be wrong here, but I think that lookup fields cant be used with automatons yet.

Thanks Marco.

Oh dear. Just as I feared. Any workarounds?

I only see one attachment in the test data based on that screenshot. There’s only one record ID listed here:

Screen Shot 2020-10-13 at 2.17.02 PM

The only place where I see two images is in the {Attachments} field, which is not necessarily part of the test data. The test data is the data you see on the right, in the automations interface. You would need to test the action/trigger again to get current data to confirm whether or not both images from that field appear in the actual test data.

That’s been the case since automations were first added. However, the fact that there’s actual data showing for that lookup field indicates that it’s now available.

On that note, @James_Quek, I suggest expanding the “ValuesByLinkedRecordId” item that appears below the list of linked record IDs (after re-testing, of course). That will reveal the actual data that’s available for those looked-up items.