Help

Attachments in Send Email Automation not Working anymore

Topic Labels: Automations
Solved
Jump to Solution
10100 36
cancel
Showing results for 
Search instead for 
Did you mean: 
Paul_Falcon
4 - Data Explorer
4 - Data Explorer

Edit:

Airtable response: 

Our engineering team has successfully deployed a fix for this issue (which arose from a recent update to our code) and any automations referencing an attachment should now run as expected without error.

It's working again. Thank you all.

---

Hello.

I've been using the Send Email action in automations for more than a year. Always worked great. In the Send Email action, in the Attachments section (Bottom) I selected the column that contained the file, and that file was attached in the email.

Captura de pantalla 2023-04-24 a la(s) 1.49.20 p.m..jpg

3 days ago, my automation worked fine. But today, when the automation triggered, there was a problem (An attachment url is disallowed):

Captura de pantalla 2023-04-24 a la(s) 1.53.48 p.m..jpg

I already turned off and on the automation, changed the trigger, changed pdf file for jpg, and always the same error.

I tried the automation with records that already triggered a few days ago and worked fine (My trigger is a Single select column, so, to trigger it again, I deleted the value in the single select field, and select it again). Same problem.

I already wrote to Airtable Support, but I wanted to write here too, because it is a very important feature in my workflow, and maybe one of you can help me find a solution or a workaround.

Thank you very much for your help.

36 Replies 36

This works well for us. Hopefully this issue gets resolved. Thanks 

It works ! Thank you

A fix that seems to work ok for me so far (sent 2 emails) is to create a formula field which is equal to the attachment field, and in the automation I just put When {formula fieldname} contains dl.airtable in the conditions.

They send straight away.

 

20 seconds isn't working for me with this before the send action with a delay in script

function delay(ms) {
var limit = new Date();
limit = limit.setMilliseconds(limit.getMilliseconds() + ms);
while ((new Date()) < limit) {
// do nothing
;
}
}
delay(20000); //delay 20 second

This works well for us. The problem is solved, Thanks

This is amazing. Thank you!

lukefron
4 - Data Explorer
4 - Data Explorer

This is happening to our base today. It was working perfectly up until today. 

Our trigger is when a pdf is put in the attachment field, an email is sent to three people in our company that is just the pdf that was added to the record.

I've tried changing a few things around and we keep getting a fail to run.