Help

Re: cannot assign list of object to collection of complex types

Solved
Jump to Solution
3571 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Skidz
6 - Interface Innovator
6 - Interface Innovator

What does this mean?

"cannot assign list of object to collection of complex types"

I can't select any field values. And how do I make it so I can select it. 

Skidz_0-1671085790057.png

 

17 Replies 17
niikostg
4 - Data Explorer
4 - Data Explorer

Hi everyone, i contacted Airtable support and this is their response : 
«Thank you for sharing that! I'll have this escalated to our technical team since this affects multiple users. I'm unable to see anything internally I'm afraid. I know it's not ideal and I apologize for that. I'm going to mark this as high priority in order to get this solved in no time.»
So let's hope it doesn't take too much time ! 

matt-pwi
5 - Automation Enthusiast
5 - Automation Enthusiast

I'm running into this problem as well. All I'm trying to do is pull a list of emails from a 'Find records' action and it won't do it, even though I'm copying from another automation that is currently working and exactly the same

Bob_Dudley
4 - Data Explorer
4 - Data Explorer

I'm having the same problem. Worked fine a few days ago and now I can't replicate the automation. 

As others have reported - the old automations are working fine with this functionality but I can't set up any new ones that have this functionality - I just get the 'cannot assign list of object to collection of complex types' message when I try.

Started happening Yesterday

Shayne_Bundy
6 - Interface Innovator
6 - Interface Innovator

Same issue here! Hoping for a fix soon.

theavandiepen
5 - Automation Enthusiast
5 - Automation Enthusiast

Airtable support just got back to me saying they've been able to fix the issue and I can confirm it's working again for me. From their email:

Thank you for hanging with us while our engineering team worked on a fix for the Find Records action step being unavailable to bring in values to the following step. The fix for this is officially released. You may need to refresh your browser or clear your cache for the fix to take effect.

Please don't hesitate to reach back out to Support if you continue to have any issues with this.

Cian_Egan
4 - Data Explorer
4 - Data Explorer

Tested and it now works, quick fix...

CalRey
4 - Data Explorer
4 - Data Explorer

Was there a solution found to this beyond just emailing support? I am having this same issue now.