Help

Error deleting record via automation script

Topic Labels: Automations
532 2
cancel
Showing results for 
Search instead for 
Did you mean: 
corb
6 - Interface Innovator
6 - Interface Innovator

I am trying to delete some records from a child table when the parent record is removed. To do so, I have created a view on the child table showing records where the parent link field is empty. On my automation, the trigger is set to be when a record enters that view, the automation fires.

 

 
The automation is firing but I get an unexpected permission related error I have not seen before. I am the workspace owner. I can manually delete rows in the UI. This seems simple....what am I doing wrong? I have other delete automations that are still working fine.
 
Error: You are not permitted to perform this operation at main on line 
 
 
Code is below
 
let table = base.getTable("tablename")
let inputConfig = input.config();
let recordId = inputConfig['recordId']
await table.deleteRecordAsync(recordId);
2 Replies 2
Sho
11 - Venus
11 - Venus

I tried it and it worked fine.
Is it an effect of the incident?

corb
6 - Interface Innovator
6 - Interface Innovator

I ended up creating another table, same structure, repointing all links & automations to that table, and everything worked. So I have no idea why the prior one didn't work.