Help

Re: Having problems with automations and dynamic conditions

Solved
Jump to Solution
1345 3
cancel
Showing results for 
Search instead for 
Did you mean: 
cris_orange
5 - Automation Enthusiast
5 - Automation Enthusiast

So I'm running into an error that I can't seem to fix. Whenever I try to set a condition based on a linked record or a formula field, I get that an unknown error has occurred.

My first table, products, have a linked field to a record inside the main product master where the product's vendor is linked. So I've created a lookup field for the vendor record id and stored it inside my products tableThe value for that record is "recSdTazTLqgiGtBb".

My second table, Vendor IDs, which contains all of my different Webflow IDs, is also linked to the vendor in the table. Here I get the exact same field value "recSdTazTLqgiGtBb".

Now I want to run automation that temporarily puts a webflow ID into my products record that I'm trying to edit. The trigger is an update to the action field, which works fine.

The next step is a conditional logic group that asks for the status of my product record, which also works just fine.

Next, I'm trying to find the correct record in my Vendor ID Table. So I try to set the condition "Where Vendor (Vendor ID table) is Vendor (Product table) (both linked records, not dynamic). I immediately get the correct result that I am looking for. But If I do the same with dynamic fields, I either get an empty result (use of ID) or the error message that an unknown error occurred (use of Name). 

The same happens if I directly ask to check for the stored record ids. I always receive an unknown error occurred, and it drives me mad.

I hope I could describe my problem and hope that someone here can help me.

1 Solution

Accepted Solutions
cris_orange
5 - Automation Enthusiast
5 - Automation Enthusiast

Oh I just figured it out, holy hell...

So I needed to create a lookup field inside my webflow data table for the client record and now if i am checking it to that it works.

Well thanks @TheTimeSavingCo for being my rubber duck in that case

See Solution in Thread

6 Replies 6

Hmm could you provide screenshots of the relevant tables please?  Sorry, I'm finding it hard to visualize!

Sure so this is the filter set with static fields as you see in the second screenshot it returns me exactly the value that I am looking for

Bildschirmfoto 2023-06-16 um 15.52.10.png

Bildschirmfoto 2023-06-16 um 15.52.15.png

 

But as soon as I try to match the conditions dynamically

First try with IDs

Bildschirmfoto 2023-06-16 um 15.56.08.pngBildschirmfoto 2023-06-16 um 15.57.09.pngBildschirmfoto 2023-06-16 um 15.56.32.png

Or with Name values this one

Bildschirmfoto 2023-06-16 um 15.58.06.png

So I made some progress. I can at least filter it to the correct vendor

Bildschirmfoto 2023-06-16 um 16.39.39.pngBildschirmfoto 2023-06-16 um 16.39.48.png

 

But I still can't narrow it down to the 2nd entry. I only need the row with "Möbel Knappstein" so my automation can work correctly. For example when I try to check the Record ID (from Kunde) I always get disabled options with the tooltip "no valid nested options"

cris_orange_0-1686927015923.png

 

cris_orange
5 - Automation Enthusiast
5 - Automation Enthusiast

Oh I just figured it out, holy hell...

So I needed to create a lookup field inside my webflow data table for the client record and now if i am checking it to that it works.

Well thanks @TheTimeSavingCo for being my rubber duck in that case

Ha glad you got that sorted!

Hey, I'm stuck on a similar issue. Did you figure it out?