Last Changed Date not populated in email

Topic Labels: Automations
1292 6
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

This seems to easy to not have been answered somewhere; I must be asking the wrong questions.

If I send an automated email which includes a column for “Last Modified Date” my column is empty, even when there is a date on the actual table. What do I need to do to fix that? Assuming that’s just one of the quirks of Airtable, will a formula field repeating the data solve the problem?

Thanks everyone.

6 Replies 6

I just ran a test and was able to retrieve the value of a last-modified-time field within the automation. Try re-testing your trigger step. If you’re still in the testing phase of the automation configuration, and you added the last-modified-time field after you began building the automation, its value won’t be contained in your test data until you re-test.

If that doesn’t fix it, could you please share screenshots of your table and your automation setup?

Sorry, been crazy busy and couldn’t return to my automations for a bit. I just seem to have a problem with grids populating correctly in general it seems. I am now trying to automate an email that will have some roll up fields. It is not working correctly either.

Re-testing the trigger step did nothing, other than verify that it tested correctly.

None of the things I am asking to be in the grid has been added or modified since I started working on the automation (true of both automations).

This is from the second email automation I am doing, but results are similar.



Table Being Referenced:

I am well aware that the table doesn’t have a lot of visible columns, but the first automation had all of the columns I needed visible in the view and that didn’t seem to improve the situation (populating in the email grid.)

Thank you for helping me, I’m a little stumped on this one.

This probably ain’t it but regarding errors being thrown by new records wich were technically never modified after creation, you should use a formula field along these lines:


Returning to this, and now I’m not sure what the issue is any more. Are you saying that the contents of the email where you’re inserting the rendered grid don’t contain all of the actual data from the record?

One thing that I just noticed is your trigger: When record enters view. What is the specific filter setting on that view? I can see the field name that’s being filtered in the second screenshot, but knowing the exact filter setup would be helpful.

One thing to keep in mind with this type of filter (as well as the “When record matches conditions”) is that the automation will be sent a triggering record’s data as it exists at the instant that it enters the view. In short, if you change something about that {* Order Type} field so that it enters the view, but then you keep editing other fields in that same record, those later changes won’t be caught by the automation. Perhaps that’s what’s happening here?

6 - Interface Innovator
6 - Interface Innovator

I believe there may have been a problem with Airtable itself, as I went to confirm which columns I had and which were or were not populating and got a whole new set up from Airtable (last time I was working on automations it all remained in the right side bar, now it is full screen.) Re-testing my automations resulted in the grids populating correctly, as opposed to missing data and columns. I have answered questions and/or responded to everyone below just in case they wanted their questions answered, but I currently consider the problem solved.

Thanks again everyone for the help. It was really appreciated.

@Dominik_Bosnjak: I’m not sure where I would put that formula? As a formula column to see if I can get the information that way? I’m probably still going to keep the formula, as I can already see use cases for it with the stuff I am working on, but I don’t think that will work with this problem, as I tried a couple different ways to get the column to populate, including several formula columns. No dice at the time of the original post.

@Justin_Barrett: That is correct. The grid in the email does not include actual data from the record, but that statement is true for only some columns. These columns would have been populated long before it entered into the view, so I don’t think that is it either.

The filter has two parts (the second not being enabled yet, otherwise the tests would fail)

  • Filter by order type to include specific types
  • Filter by order date, where order date is 14 days from now.

Glad to hear that it’s working!