My automations have broken

Topic Labels: Automations
3576 5
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

The interface (GUI) to automation has changed for me in the last few days. Not sure if that is related, but many of my automations across multiple bases have stopped working. The only pattern I have so far established is the trigger (I mostly use record entered view) fires correctly. The log shows “In progress” as the title and under the first action (mostly a script) it says “Step pending”. It then gets stuck there, doesn’t time out, doesn’t error! I have a PRO plan and am no where near any limits, as best as I can tell. Weirdly, if I create a brand new automation on a test base it works, but editing an existing automation, turning it off and on has no effect. If I test the script from the edit panel then I get an error that just says “Unexpected error has occurred, contact support”, I get the same error even if I completely blank the script or do a simple console.log(‘test’). I have raised a ticket with support but given I am in Australia I need to wait lots of hours before they even see it and I wanted to know if anyone else was having trouble or if I have overlooked something simple! The scripts I run are mostly fetch to POST urls, are super simple and look very similar to the example in the docs. The URLs are up and working and havn’t changed, (the test automation I mentioned works with the same URL, i.e. it is definately not the URL). Issue is with mutiple automations across multiple bases, but I only have a single workspace. My automations only trigger a few times a week in most cases so I’m not sure how long the issue has been there but could be a couple of days.

5 Replies 5
5 - Automation Enthusiast
5 - Automation Enthusiast

This is an identical situation to what I am suffering today.
No changes my end - It fires the trigger without issue and then script is “step pending” with nothing happening (no timeout/failure etc.) and nothing edited for it to occur.

Pending airtable feedback on this, but I fear reading your issue, its an issue their end, not ours.

same here we need a quick fix pls

It is on their end.

4 - Data Explorer
4 - Data Explorer

This is happening to me today. Trigger is firing fine but then the next step is stuck on “in progress”. Anyone know how long this issue takes to sort out?

6 - Interface Innovator
6 - Interface Innovator

I am now running into this issue with all automations stopped at “In progress”. I checked the automations and nothing was changed from a few hours ago. Also, ran a few test automations and they run perfectly to update the field values. This has to be an AirTable issue and not something on our end, is there a post or announcement made when there are network or issues within AirTable posted?