Help

Upcoming database upgrades. to improve our reliability at 03:30 UTC on Feb. 25 / 7:30pm PT on Feb. 24. Some users may briefly experience slow load times or error messages. Learn more here

Updating the record failed due to insufficient permissions

Topic Labels: Automations
3693 9
cancel
Showing results for 
Search instead for 
Did you mean: 

Hi everyone,

I have an automation, where the automation should copy a field whenever a new record is created. It should copy the data from Instance field to All Events field in the same table. However I get an error that says “Updating the record failed due to insufficient permissions.”. I made this automation as the owner of the base and I have absolutely no idea what or where is going wrong.

Does anyone have any recommendations to solve this problem?

Thank you in advance!

9 Replies 9

The field that you are trying to update it’s a link to another table?

Hi,
I have the same problem and yes it’s when I’m trying to update a link to another table. Do you know what is the problem ?

Yes it is a lined field. But changed a bit the schema and now it is working.

How did you do that? :winking_face: I’m trying to update a link field as well, using automations.
I encountered the same error message: “Creating the record failed due to insufficient permissions.”

Thank you!! Be well,

I reversed the flow. I have 3 tables that play a role here. I have ‘Instance’ ‘Proposal’ and ‘All Events’. First The automation is living in ‘Proposal’. I wanted the automation to copy and paste the linked ‘Instance’ whenever a new Proposal occurs, in the same table, to ‘All Events’ field. It gave me back the same error. But I changed it, and made it like the following: When a new proposal is entered, do not make this automation in the same table, but go to ‘All Events’ and paste the Instance there. This way all of the 3 tables are connected. In my opinion, both methods should work so I guess this is sort of a bug.

If I understand well, you link the record not from its table but from the linked table… So you must find the correct record in the linked table. I will try and see how it works.

One thing it took me far too long to spot was that the Field permissions of the field I was trying to update were wrong! Check that first folks.

Hi Community,

I have automation running that needs to update linked record once record is created.
Automation has condition. The first condition checks the name of one field and then updates the linked record. The second condition checks the same field but with different name and it should update the linked record.
The strange part here is that it works with the first condition but not with the second. So let’s say it works if I want to update linked record with text A but not if I want to put text B. I think that is a bug and not something with my automation. The error in automation suggest issue with permissions but that is not the case because it updates the filed if the update text is different.

Could you help with this?

This was driving me crazy when I tried adding all the fields I wanted individually. Then I decided to try adding just "Airtable Record ID" and it actually worked.